Форум

Страница 1 из 11
Модератор форума: dr40 
Форум | www.SAMP-TEAM.com » Wiki SA-MP » Вопросы по скриптингу » Видны удалённые объекты
Видны удалённые объекты
Проблема такая:
Удалил несколько объектов в МТА, в pawno добавляю:
Код
RemoveBuildingForPlayer(playerid,11091,-2133.5547,-132.70312,36.13281,47.244934);  
RemoveBuildingForPlayer(playerid,11011,-2144.3516,-132.96094,38.33594,32.972034);  
RemoveBuildingForPlayer(playerid,11009,-2128.5391,-142.84375,39.14063,69.713104);

Но при движении мышки, объекты появляются, и становятся прозрачными, можно бегать сквозь них.
Вот видео:

Может кто сталкивался с такой проблемой?
22.09.2014 в 13:12
Это не объект, это его LOD; скачай чистую гташку без всяких модов и измененных параметров
22.09.2014 в 16:44
гта без модов, недавно переустанавливал.

это не lod, а lod = 11376
Код
<removeWorldObject id="removeWorldObject (crackfactjump_SFS) (1)" radius="32.972034" interior="0" model="11011" lodModel="11376" posX="-2144.3516" posY="-132.96094" posZ="38.33594" rotX="0" rotY="0" rotZ="0">


Уже решил проблему, так:
Код
RemoveBuildingForPlayer(playerid,11011,-2144.3516,-132.96094,38.33594,100.972034);
RemoveBuildingForPlayer(playerid,11376,-2144.3516,-132.96094,38.33594,100.972034);

где в первой строке удаляю объект, а во второй lod

у остальных lod = 0, поэтому не добавлял

ps: нашёл это решение не просторах инета
22.09.2014 в 17:36
Ну я имел ввиду, что у тебя виден LOD, а не объект, хотя LOD должен отображаться на большом расстоянии. Ну а самп это не мта, в нем объекты без LOD'ов не удаляются.
22.09.2014 в 21:56
Цитата [S]ilverbac[k] ()
у тебя виден LOD, а не объект, хотя LOD должен отображаться на большом расстоянии. Ну а самп это не мта, в нем объекты без LOD'ов не удаляются.

Да, согласен.
22.09.2014 в 22:00
Для удаления всегда использую редактор от бета тестера сампа. Там удаляется вместе с лодами.
24.09.2014 в 00:58
Форум | www.SAMP-TEAM.com » Wiki SA-MP » Вопросы по скриптингу » Видны удалённые объекты
Страница 1 из 11
Поиск: